Announcement

Collapse
No announcement yet.

Problems with Radeon sapphire x1950 gt drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with Radeon sapphire x1950 gt drivers

    Hi i have recently bought an ati sapphire x1950 graphics card. I have deleted my old nvidea drivers. I then downloaded the ati x1950 series drivers and it says i have incorrect hardware or software. I have windows media center and downloaded these drivers from here;

    http://game.amd.com/us-en/drivers_ca...ce/radeonx-mce

    What is happening? My pc should easily run this graphics card! Do i need to change the bios to allow the new g-card? Any help would be greatly appreciated. Maybe even a walkthrough on installing a graphics card. Thanks

  • #2
    Welcome to Free PC Help sshardlow.

    Those are the correct drivers. Have you tried installing the drivers from the cd?

    Here are the proper software instructions (note the DAO):

    http://support.ati.com/ics/support/d...estionID=20870

    Also note that you have two options for that driver.

    If all that fails, confirm the model number by looking directly at the card. Also, if someone has played around with XP MC they may have installed XP and not the MC part. So, right click on My Computer and choose Properties. On the General tab it should show XP Media Center Edition.
    Last edited by Seth; 14-03-2008, 12:51 PM.
    Need help with your computer problems? Then why not join Free PC Help. Register here

    If Free PC Help has helped you then please consider a donation. Click here

    Comment


    • #3
      It doesent work still!

      I am actually losing my mind. Its putting out an image onto my pc why wont it install the drivers. I bought it off ebay and it works fine part from the drivers. Ive looked at the sapphire drivers (the second brand name) and it has bios settings but in a weird file.

      http://www.sapphiretech.com/us/support/drivers.php

      Thanks 4 ur help anyway

      Comment


      • #4
        I don't know where you're seeing the "bios" settings.

        So did you get it installed? If not, the link you posted shows various versions of the card. Have you double checked the version you need and tried to install that driver?
        Need help with your computer problems? Then why not join Free PC Help. Register here

        If Free PC Help has helped you then please consider a donation. Click here

        Comment


        • #5
          no i havent

          Comment


          • #6
            Haven't what sshardlow?

            Managed to get it installed?

            or

            Checked the version and installed the driver?

            Comment

            Working...
            X