• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

Can't Upload

beans307

FPCH New Member
Joined
May 20, 2008
Messages
1
#1
I've been having this issue for a few days. Whenever I try to upload anything, it uploads very slowly (about 2kb per sec) or the upload simply fails. This happens everywhere, Photobucket, Mediafire, Freewebs, etc. I've tried several speed tests and I always get the same result. The download portion works fine (7-10mb per sec), but the upload test won't even start.

I've tried everything I could think of. I've tried using both Firefox and Internet Explorer, running them as administrator, terminating any unnecessary processes, turning off my anti-virus program and firewall, and even unplugging my modem for a few hours, but nothing has worked.
I'm running Windows Vista Home Premium, my ISP is Road Runner, and my modem is a Touchstone Telephony Modem (I can't determine the model. It could be either the TM402P or the TM402G).