• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

Hey, My AV Found Something In Svchost.exe, and deleted it!

Snaily

FPCH Member
Joined
Jul 16, 2007
Messages
8
#1
My AV, (curretnly using AVG 7.5) Found a trojan in svchost.exe, and what did it do, but went and deleted the damn file. My antivirus has no backup, and yes, im considering a restore, but restoring to a point were i DO have a trojan sounds merely stupid to me. Either way, when i boot up now i get:

Windows Cannot file svchost.exe Make sure you typed the file name correctly and, and then try again. To search.. bla bla bla.

Anyway, the thing is, exactly the same thing happened me before on a previous computer, and i KNOW i fixed it without restoring or using the XP boot disc. (I dont have this on me at the moment, i hold little faith in the recovery console anyway) I was just wondering if anybody here had a fix. Thanks, if theres not, i guess im going to have to restore. Thanks for the help though.
 

danzil

FPCH Member
Joined
Jun 29, 2007
Messages
885
Location
Gloucestershire
PC Experience
Operating System
#2
can you ge into safe mode..tap f8 at startup then do a system restore.
if not the xp cd is the only way i can think of.
regards
danzil.
ps you could recover another way buts thats a last resort,and extremely complex,and very hard to do in a forum.,but i maybe able to email you a guide
 

Snaily

FPCH Member
Joined
Jul 16, 2007
Messages
8
#3
Well, turns out that bugger of a trojan had disabled my system restore and regedit. Allthough this is no biggie.


I Used the annitiative, went to my other computer and found the svchost.exe file, and came back to my pc. Anyway, looks like windows did the job it should do and recreated the file after i restarted anyway, so if anybody else gets this. simply try restarting.

So my problem is sorted, i simply reinabled system restore and regedit. Im definetly going to be keeping a closer check on what AVG deletes in the future though.

Thanks Anyway.
 

Boomshanka

FPCH Member
Joined
Sep 11, 2007
Messages
10
#4
windows will normaly re-instal all the major files it needs to boot on the sceond restart if not you can repair windows using the windows disk going though the setup and hit "R" for repair instead of enter to install thus keeping all your info whoop whooop