• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

Lost DVD drives

gregmiller

FPCH New Member
Joined
Jun 15, 2007
Messages
3
#1
Help!!

My PC has "lost" both my DVD burner and my 2nd Lightscribe burner. When booting up it shows as new hardware found and loads both drives but they do not show on "my computer". When I explore device manager, it shows the devices with a yellow exclamation mark and states that drivers are loaded but devices cannot be found.

I'm runnig a Windows XP Media centre, SP2, Pentium 4 3.00 GHZ dual processor with 1Gb ram.

Greg
 

danzil

FPCH Member
Joined
Jun 29, 2007
Messages
885
Location
Gloucestershire
PC Experience
Operating System
#3
hi greg.
have you made any changes to your system lately...ie software or hardware......
you may want to check that the ide/sata cable is firmly conected to the drives and they are recieving power....
if this does not help then try a system restore.
to do this go to start>all programs>accessories>system tools>system restore..
pick a date previous to this error.then restore...
if that doesnt work please post back so i can try to help more.