• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

Motherboard/CPU.......... Where does the problem lie?

Novox

FPCH New Member
Joined
Feb 21, 2007
Messages
2
#1
Hey guys
Basically I forgot to mount the motherboard on the plastic mounts(never done that before) and i believe the motherboard shorted out. So i mounted the motherboard and then turned it on. The PSU fan doesn't turn on but the Power LED does come on. Whats wrong. I dont know is the PSU or the Motherboard.

Also whats the probability that all the components on the board are fried.

Cheers
Novox
 

Novox

FPCH New Member
Joined
Feb 21, 2007
Messages
2
#2
Sorry forgot some stuff.
THe PSU is a mercury 400W/
Motherboard as a Asrock AM2NF6G-VSTA .
Processor is AM2 4200
Nvidea Graphics Card 7600GT
1GB Corsair Memory.

Thats all folks
 

Jamey

FPCH Member
Joined
Jan 21, 2006
Messages
333
Location
Telford, UK
#3
Well I'd definitely suggest changing the PSU first; it is the cheapest component and rules out a lot of potential problems.

I doubt too much damage has been done to many components, if anything it will be the motherboard or processor. I think you need to change the PSU and see what results you get from that.