• Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

New first gaming pc, No signal on monitor!!

umayr

FPCH New Member
Joined
Aug 8, 2016
Messages
4
PC Experience
Beginner
#1
its been 3 weeks pc was custom built by me then suddenly yesterday on my monitor it says no signal!! someone please help me idk what to do. i tried everything on every youtube video, took all wires off took out ram and gpu etc. is my motherboard dead??? how its only been 3 weeks the fans and everything still turn on as if theres nothing wrong. HELP ME PLEASE!!!! PLEASE ;'(
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,212
Location
Wirral UK
#2
Hi and welcome to FpcH

Do you have another video card - an old one - that you can try ?
If so - swap them over.

Do you have on-board video that you can try ?
 

umayr

FPCH New Member
Joined
Aug 8, 2016
Messages
4
PC Experience
Beginner
#3
i have on board intel graphics, i plugged the hdmi cable into motherboard hdmi but still nothing came on screen. i took the graphics card out when doing this...i dont know what to do
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,212
Location
Wirral UK
#4
It could be a fault with the HDMI cable.

Are you getting power to the motherboard?
Are fans turning?

If you have a volt-meter check the PSU output at the connection to the motherboard.
 

umayr

FPCH New Member
Joined
Aug 8, 2016
Messages
4
PC Experience
Beginner
#5
i tried new hdmi cables so it cant be that. i rebuilt the pc last night and now it wont even power anything! before the fans were running but now no fans turn on but the mouse lights still turn on. could it be my power supply?
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,212
Location
Wirral UK
#6
could it be my power supply?
Looks like it could be.

Do you have an old PSU to try - it doesn't have to be the same wattage.
Try it using the on-board graphics - leave your Video Card out for the time being.
 

umayr

FPCH New Member
Joined
Aug 8, 2016
Messages
4
PC Experience
Beginner
#7
i tried it i took the video card out but still ni response from anything. no fand turn on no nothing. only the mouse lights up . what do i do now