• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

No autoplay message

shrimply

FPCH Long Term Member
Joined
Jan 5, 2008
Messages
457
Location
Galashiels, Scottish Borders
PC Experience
Beginner
Operating System
Windows Vista - Home Premium
#1
Yeah, sorry for all the questions but know I've found you lot there will probably be a lot more. Also not sure if this is the right place to put it, maybe it should be in multimedia.

I imagine this ones pretty basic though.

I'm sure I used to get autoplay messages for both SD cards and flash drives, I could be losing my mind but lets pretend I'm not.

I don't get an autoplay message and its not really a problem but it is quite handy to get them. I can still access everything by going through My Computer. I do still get the messages for DVDs and CDs.

Both card reader and USB ports are built into the laptop, don't know if that's important.

Thanks
 

maynardvdm

FPCH Long Term Member
Joined
Feb 7, 2007
Messages
3,117
Location
South Africa
#2
Hi
You can change autoplay setting by right-clikcking on the flash drive select properties and look under the autoplay tab. Not sure if this will work for the sd cards but you can try.

Cheers
 

shrimply

FPCH Long Term Member
Joined
Jan 5, 2008
Messages
457
Location
Galashiels, Scottish Borders
PC Experience
Beginner
Operating System
Windows Vista - Home Premium
#3
Thanks, just to be difficult i don't get an autoplay tab, I've looked under all the tabs and there doesn't seem to be an autoplay option anywhere.
 

shrimply

FPCH Long Term Member
Joined
Jan 5, 2008
Messages
457
Location
Galashiels, Scottish Borders
PC Experience
Beginner
Operating System
Windows Vista - Home Premium
#5
Nope when I click on a drive to fix, I get

Microsoft Auto Repair Wizard has Stopped working.

Guessing its because it doesn't work with Vista.
 

AdvancedSetup

FPCH Long Term Member
Joined
Jan 9, 2008
Messages
819
Location
34° 12' 35" N, 118° 29' 21" W
#6
No it doesn't work with Vista. Sorry about that.

I'll read back through the post and see what the issue is and what has already been suggested to see if I can find something for you and get back with you tomorrow if someone else has not already stepped in.

Was it ever there before on Vista? I will have to fire up my Vista and take a look as I know Vista does a lot of things differently now days.
 

shrimply

FPCH Long Term Member
Joined
Jan 5, 2008
Messages
457
Location
Galashiels, Scottish Borders
PC Experience
Beginner
Operating System
Windows Vista - Home Premium
#8
Thanks and sorry that i wasted your time.

According to this i never got autoplay messages



"If you have connected a volume device to your computer (for example, a USB flash drive or external hard drive), that device will not appear in the Devices section of AutoPlay. To browse the contents of volume devices, open Computer.

AutoPlay only lists non-volume devices (for example, some digital cameras, video cameras, and phones). This is because these devices don't use a standard file system and AutoPlay cannot browse the contents of these devices to see what types of files they contain."

Which is strange because I'm so sure i used to but obviously not.
 

RandyL

Administrator
Joined
Jan 22, 2003
Messages
4,878
Location
USA, Nebraska
PC Experience
Very Experienced
#9
Hi;
Not entirely true. I get the AutoPlay notification for my CF card and USB thumb drive.

Go to Control Panel>Hardware and Sound>Autoplay.
If Control Panel is in classic view just open AutoPlay.

Put a check in “Use AutoPlay for all media and devices”
Select your AutoPlay default actions.

Not all devices will be listed in the device section at the bottom per the Vista help files that you just mentioned above.

Save your selections and exit.

RandyL
 

shrimply

FPCH Long Term Member
Joined
Jan 5, 2008
Messages
457
Location
Galashiels, Scottish Borders
PC Experience
Beginner
Operating System
Windows Vista - Home Premium
#10
Hi, thanks the reply and sorry this has taken me so long, Still no luck though.

Any more suggestions welcome, but don't worry too much about it.
 

Seth

FPCH Long Term Member
Joined
Dec 17, 2007
Messages
2,268
Location
Canada
Operating System
Windows Vista - Home Premium
#11
Shrimply,

Quit apologizing:)

Free PC Help welcomes all of your questions. Problem is, Vista is so new that even the best techs are still trying to figure it out.

...and so is Microsoft! LOL
 

AdvancedSetup

FPCH Long Term Member
Joined
Jan 9, 2008
Messages
819
Location
34° 12' 35" N, 118° 29' 21" W
#12
On Windows Vista AutoPlay does not automatically launch but should bring up a list of options for you to choose what to do.

Please take a look at this Microsoft article and review your registry setting there.
NoDriveTypeAutoRun

The key you need to look at should be located here: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer


The default is 95 in Hexadecimal or 149 in Decimal if you set it to 0 it should enable AutoPlay for all devices which should bring up a LIST of options to perform when a new device is found.
 

shrimply

FPCH Long Term Member
Joined
Jan 5, 2008
Messages
457
Location
Galashiels, Scottish Borders
PC Experience
Beginner
Operating System
Windows Vista - Home Premium
#13
Thanks, it was the list I was looking for, sorry if that was unclear.

Have to say the above post made very little sense, yeah I know nothing.

Anyway, I followed the thing and entered zero in the box. If that was what I was supposed to do it made no difference. If it wasn't would you mind explaining more simply.
 

maynardvdm

FPCH Long Term Member
Joined
Feb 7, 2007
Messages
3,117
Location
South Africa
#14
AdvancedSetup said:
On Windows Vista AutoPlay does not automatically launch but should bring up a list of options for you to choose what to do.

Please take a look at this Microsoft article and review your registry setting there.
NoDriveTypeAutoRun

The key you need to look at should be located here: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer


The default is 95 in Hexadecimal or 149 in Decimal if you set it to 0 it should enable AutoPlay for all devices which should bring up a LIST of options to perform when a new device is found.
The key AS is refering to is in the registry so you need to go Start->Run then type regedit and HKCU=HKEY_CURRENT_USER.
 

shrimply

FPCH Long Term Member
Joined
Jan 5, 2008
Messages
457
Location
Galashiels, Scottish Borders
PC Experience
Beginner
Operating System
Windows Vista - Home Premium
#16
lol, vista all over. I did manage to get in to the registary and entered a 0, which is what I think I had to do.

It doesn't really matter, I take that this is the simple fault it appears to be and isn't likely to be linked to any viruses or malware

Thanks for all the help.
 

shrimply

FPCH Long Term Member
Joined
Jan 5, 2008
Messages
457
Location
Galashiels, Scottish Borders
PC Experience
Beginner
Operating System
Windows Vista - Home Premium
#17
Well, dunno if I should be bumping up such an old post but I found the solution and cause, well at least I think I did.

It seems the problem is caused by VMware even after its been uninstalled and the hex value needs to be set to 000000fb. Didn't work that out for myself by the way, found it else where.

But its working so I'm happy.