• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

pc will not recognise my digitial camera

azza11

FPCH New Member
Joined
Jan 5, 2008
Messages
2
#1
Hi guys I'm new to the forum and thanks very any advice and help.
I have two digital camera's and when connected to the pc I get a message stating new hardware detected, but nothing in windows explorer. I've checked the plug and play option in services and that's ticked. I've deleted then re-intalled the drivers but to no avail. I've even bought a digital card reader but the pc won't recongnise that either. I have plugged other hardware into the USB port and they work fine such as the printer.

Any help would be greatly appreciated before I re-install Windows.
 

RandyL

Administrator
Joined
Jan 22, 2003
Messages
4,878
Location
USA, Nebraska
PC Experience
Very Experienced
#2
Hi azza11;
Please don't re-install Windows. That won't help and I would hate to see you go through all that for nothing. Can you provide just a little more information to help?

Make and model of computer.
Vista or XP I assume. Can you provide details on that.
Make and model of the digital cameras.
Can you see the devices in My Computer?
Have you tried a different USB port?

I ask just in case that info may be needed for this issue. Please post back as I'm sure someone here will assist you.

RandyL
 

azza11

FPCH New Member
Joined
Jan 5, 2008
Messages
2
#3
Hi Randy,

Ask whatever questions you want as I'm sure I'll miss something. My cameras are a Fujifilm finepix a330 and a Vivicam 6324. I've re-installed the device and it doesan't come up in my computer. I've tried different USB ports to no avail and I'm running windowx XP. I've run a registry cleaning programme, spyware doctor and virus checker. Any ideas would be greatly appreciated.

many thanks

Azza.
 

RandyL

Administrator
Joined
Jan 22, 2003
Messages
4,878
Location
USA, Nebraska
PC Experience
Very Experienced
#4
Hi azza;
It appears that XP should have the drivers you need for the fujifilm but look at the support link anyway. There is an update for the USB driver there as well as installation instructions in PDF.
http://www.fujifilmusa.com/JSP/fuji...p?dbid=804768&prodcat=710738&sscucatid=664260

As for the vivitar vivicam check their downloads for drivers and PDF manual.
http://www.vivitar.com/support.asp

Check Device Manager for any yellow ? to see if there is any trouble with drivers.

That's all I have for now. Plwase post back.
RandyL