• Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

sd slot not working

tismehi

Free PC Help Contributor
Joined
Nov 13, 2008
Location
belfast
PC Experience
Some Experience
i have an acer aspire v5 i3.500gb, (250 free), hdd, 4gb ram, windows 8.1

all is well with this machine except for the fact that the inbuilt sd memory card slot does not function.
when i put any card into it, absolutely nothing happens. it used to give me the option to look at the drive contents. the slot does not even show up in "my computer" or "this pc".

i have not been using the laptop too much this past year as i seem to have more time for the smart phone and tablet, (android). but it would be handy for sd memory card data transfers, et. i can still put the cards into a dongle and do it this way but it would be preferable to be able to use the original drive.
it may have stopped as windows was updated to 8.1
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
Hi

Does it show up in Device Management ?
Windows Key + S > type in .....device manager.... Click on the Device Manager box.

Is SD Host Adapter listed?

Are there any yellow exclamation marks or red Xs ?
 

tismehi

Free PC Help Contributor
Joined
Nov 13, 2008
Location
belfast
PC Experience
Some Experience
Under device manager, memory technology devices it lists realtek PCIE card reader.
I'm not at all sure this refers to the sd card reader slot but I know of no other.
there's no reference anywhere to 'sd host adapter' and there are no exclamation marks of any colour.
 

Plastic Nev

Deceased - sadly missed
Joined
Oct 19, 2008
Location
Lancashire
Open the search box again, then type in Disk Management, not sure how it is labelled in Windows 8.1, however it says "Create and format hard disk partitions" in Windows 7, it may say the same, just click on it, when the window opens it should show you the normal hard drive and if the laptop has one the CD DVD drive. It may or may not show the card reader at that point, however if the reader is working, it should show up when you put an SD card into the slot.

If still nothing comes up, there is the possibility the reader has a problem with the contacts for the card.

I have to ask are you putting the card in the right way up, or worse has a card been forced in the wrong way up, if the second, the contacts may have been bent out of the way and will no longer connect with the card.

Nev.
 

tismehi

Free PC Help Contributor
Joined
Nov 13, 2008
Location
belfast
PC Experience
Some Experience
the machine is only ever touched by me and the card always goes in with the label uppermost. i can't ever imagine trying to put one upside down or back to front. it would be like putting a cd in a drive the wrong way - possible but unlikely.
i did as suggested and on 8.1 it is the same as you suggest Nev. the hdd and cd rom are listed but the card reader is not. i inserted a card and there is no change in the display. i have tried other cards too and all are from cameras and other machines that all work well.
 

Plastic Nev

Deceased - sadly missed
Joined
Oct 19, 2008
Location
Lancashire
Hi, unless Ken has an idea I am afraid that to me it looks like the reader has died, it is obviously not recognising there is a card inserted as doing so should open a new entry in disk management.
If it hasn't been used in quite a while there is the possibility that the small leaf contacts have become oxidised, however getting at them to clean them is more than likely not possible.
I doubt it is software related such as drivers faulty, however there is no harm in going back to the device manager page, opening that entry for the reader and uninstalling the drivers. Reboot the computer, if the reader is only short of correct drivers Windows will search for and install new drivers. It's worth a try, though if still not working after that it can only be the reader itself dead.

Nev.
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
I was going to suggest doing what Nev has just suggested :)

Give it a try - uninstall the drivers and reboot.
 

tismehi

Free PC Help Contributor
Joined
Nov 13, 2008
Location
belfast
PC Experience
Some Experience
hi Ken & Nev,

thanks for your help.
i uninstalled the driver and restarted. i now have a yellow exclamation mark, - no surprise there.
in pci device properties it states:

The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.


To find a driver for this device, click Update Driver.

of course I search the internet for the driver but it says none are available.

I'm wondering is this worth the hassle as the cards can be used another way, however cumbersome.

Joe.
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
Hi Joe

It does sound as if the reader has died.
One last try - give the driver from here a go - click here
You will need to click on "Global" or "Server" from the one at the top of the list.

Nothing lost if it doesn't work :)
 

tismehi

Free PC Help Contributor
Joined
Nov 13, 2008
Location
belfast
PC Experience
Some Experience
cheers again Ken,

i uninstalled the driver then followed your link and unzipped, updated and the reader worked - once.
after i removed the sd card and reinserted it, the reader disappeared again. I've tried this with different cards with the same result.
so it would appear to me that the reader is faulty, at least most of the time.
Joe.
 

Plastic Nev

Deceased - sadly missed
Joined
Oct 19, 2008
Location
Lancashire
Hi Joe, just one final thing, please check your device manager, have the red or yellow marks disappeared? If not, the driver hasn't installed correctly, if they have, the driver is installed but the device isn't working!

You could also try a fresh install again any way, as it seems odd that the reader worked once, then failed the second attempt.

Nev.
 

tismehi

Free PC Help Contributor
Joined
Nov 13, 2008
Location
belfast
PC Experience
Some Experience
hi Nev,

once i safely remove the sd card, the sd card reader disappears altogether. before i remove the card, i check that i can check the content, (photos).
I've tried this with 3 different cards and different brands too, same result. To access sd card contents, i first must insert the card, then uninstall the driver, restart and scan for hardware changes. when i complete these steps, the card then appears with a yellow mark. i then install the driver Ken recommended and it installs ok.
It works fine until i remove the card and then I'm back to square one again.
 

Plastic Nev

Deceased - sadly missed
Joined
Oct 19, 2008
Location
Lancashire
OK Joe, I will see if Ken has any thoughts, though it does look like there is something strange with the reader.

Nev.
 

RandyL

Administrator
Joined
Jan 22, 2003
Location
USA, Nebraska
PC Experience
Very Experienced
I was just wondering if you are removing the card properly. Do you use the "safely remove hardware"?

Have you tried turning off the computer before removing the card?
 

tismehi

Free PC Help Contributor
Joined
Nov 13, 2008
Location
belfast
PC Experience
Some Experience
hi Randy, yes I always use the proper safe removal process for sd or usb devices.

If I turn off the machine, remove card, restart the machine then reinsert the card, nothing happens. the card is not accessible.

tonight I ran "slim drivers" program and it suggested i needed a driver for the realtek device so I proceeded to let it instal. it suggested repair and now I've discovered that if I shut off the machine, insert the card and then switch on, it then finds the card ok & I'm able to use it.

weird or what?
 
Top Bottom