• Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

[Solved] Asus Strix Flare UK Layout

Joined
Mar 13, 2019
Messages
2
Location
UK
PC Experience
Very Experienced
#1
Hey first post here. So I've lived with it for quite a while now but it still bugs me, i have the UK layout of the Asus Strix Flare keyboard and the keyboard settings under language options in Windows 10 says United Kingdom layout but for some reason the '|' and '¦' are in each others place to where they are printed on the keycaps. However the other symbol on each keycap is correct.

I have also tried changing it to United Kingdom Extended but that did nothing.

Any help would be much appreciated, thanks.
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,325
Location
Wirral UK
#2
Hi and welcome to FpcH

Take a look here - it may help - click here

You could take a look at Device Manager > right click on "Keyboard" > Update driver
You will need an internet connection.

Alternatively you could uninstall the keyboard drivers from Device Manager > Reboot.
Windows will re-install the drivers.
 
Joined
Mar 13, 2019
Messages
2
Location
UK
PC Experience
Very Experienced
#3
Hi! Thanks @KenB but I had already tried those options.

According to Wikipedia some versions of the UK keyboard have them switched depending on what operating system you use.

Link: UK Keyboard Layout
  • The B00 key (left of Z), shifted, results in vertical bar (|) on some systems (e.g. Windows UK/Ireland keyboard layout and Linux/X11 UK/Ireland keyboard layout), rather than the broken bar (¦) assigned by BS 4822 and provided in some systems (e.g. IBM OS/2 UK166 keyboard layout)
  • The E00 key (left of 1) with AltGr provides either vertical bar (|) (OS/2's UK166 keyboard layout, Linux/X11 UK keyboard layout) or broken bar (¦) (Microsoft Windows UK/Ireland keyboard layout)
So to fix it I downloaded the Microsoft Keyboard Layout Creator Tool 1.4 tool, loaded the default UK version and changed the keys around. Installed the package and now I use the custom profile under languages and it works perfectly.

If someone wants to download the profile I have uploaded the zip file here: Asus Strix Flare UK Keyboard Layout

Things to note that I have changed:

¦ and | are now switched around. ¦ is now left of Z and | is now left of 1
|
is now accessed through SHIFT+` rather than ALT GR+`
¬
is now accessed through ALT GR+`

Thanks for your quick response.
 
Last edited: