• Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

[Solved]Getting Unknown USB Device (Device Descriptor Request Failed) Help me Please!

Yemi

FPCH Member
Joined
Nov 3, 2014
PC Experience
Beginner
Hello. My Laptop (Toshiba C50D-A-13G, Windows 8.1) Suddenly shut down by force! It was as if i held the power off button but i didn't. After this all my devices and mouses refused to work in the USB 2.0 Slots. Here is what i have tried already:
Reboot - Fail
Try the mouse on another Laptop to see if it's working - Mouse was Working in other Laptop.
Shut down and take battery out for a few minutes - Fail
Uninstall the Unknown USB Device and Reboot - Fail
System Restore - Fail
Change to default settings in bios mode - Fail
Run McAfee FULL Scan - Fail
Try to update drivers - Fail
Uninstall and re-install all Drivers in Universal serial bus controllers section - Fail
So far everything i have tried has Failed.
Please help me i'm getting seriously fustrated D:
Here are some Screenshots
http://epvpimg.com/0YwUb
http://epvpimg.com/tuYlf
http://epvpimg.com/gveWd
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
Hi and welcome to FpcH :)

Uninstall the Unknown USB Device and Reboot - Fail
If Windows is still recording this as a problem ( yellow exclamation mark ) after you have uninstalled it - then it seems that Windows is "seeing" hardware that does not have the correct drivers.

I doubt that this is the cause of your USB ports not working.

When you say you updated drivers - did you update the Chipset Drivers for your machine?

Take a look here - click here
See if you can update the Chipset Drivers.
 

Yemi

FPCH Member
Joined
Nov 3, 2014
PC Experience
Beginner
My machine does not show up on the list :(
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
My machine does not show up on the list
Send me a PM with the Model or Serial Number please.

Click on my name ( to the left ) then click on "Private Message"
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
I didn't have any luck with that particular page either :(

I did find this - click here

There are USB Drivers there ..........not sure if you have tried these ??

There doesn't seem to be a chipset driver which is odd.

Let me know how you get on with the USB driver.
 

Yemi

FPCH Member
Joined
Nov 3, 2014
PC Experience
Beginner
Thanks i found my Model Im just installing the USB Drivers. I Hope it works :D

Edit***

The USB Driver Install did not fix the problem :(
 
Last edited:

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
There were No Changes
Ok.
Go back to Device Manager and uninstall / delete every entry under USB Controllers
There are 13 showing in your last image.

Then re-boot.

Windows should detect "New Hardware" and re-install the drivers.

Take a look in Device Manager - let me know what is listed now please.
There will not be 13 as this list gets added to as you introduce new hardware to the USB Ports.
 

Yemi

FPCH Member
Joined
Nov 3, 2014
PC Experience
Beginner
Before i can Uninstall them all quick enough, the re-installation already begins. Im still getting the same message too.
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
Before i can Uninstall them all quick enough, the re-installation already begins.
I don't understand - the system shouldn't restart automatically.
I have just uninstalled one of my USB Controllers entries and the system didn't restart.

If you are prompted to restart click "Later"
Once all are uninstalled - then restart the system.
 

Yemi

FPCH Member
Joined
Nov 3, 2014
PC Experience
Beginner
Nooo My system doesn't restart. It's the usb controllers which keep auto installing. It's like i scanned for hardware changes (which i didn't).
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
It's the usb controllers which keep auto installing.
That's odd - most should only install if the hardware is present.

Have you uninstalled them one at a time anyway ?

Try this M-$oft "FixIt" - click here
 

DSTM

FPCH Long Term Member
Joined
Dec 10, 2007
PC Experience
Some Experience
I am thinking something you have hooked up is not compatable with Windows 8.1 hence why windows keeps on trying to install the drivers and keeps on failing.
Do you think this is a possibility? Ken.
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
I am thinking something you have hooked up is not compatable with Windows 8.1 hence why windows keeps on trying to install the drivers and keeps on failing.
Hi DSTM
It is a possibility - the thing that confuses me is .... if the device is not connected it should be possible to remove the entry from Device Manager without it re-installing immediately.
 

Yemi

FPCH Member
Joined
Nov 3, 2014
PC Experience
Beginner
I Tried un-installing them one at a time slowly. But they still automatically reinstall.
 

Yemi

FPCH Member
Joined
Nov 3, 2014
PC Experience
Beginner
My USB Slot already makes the noise that a Device is pluggged in But it's not :L
 
Top Bottom