• Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

[Solved] Lenovo Legion 5P won't use my dedicated GPU, instead prefers the IGPU.

Lucky26

FPCH Member
Joined
Jan 28, 2021
Location
London
PC Experience
Some Experience
My specs are as follows:
CPU: AMD Ryzen 7 4800H with Radeon Graphics
RAM: 8GB
GPU: NVIDIA GeForce RTX 2060
OS: Windows 10

In the past, I have been able to play games in both VR and on the flat screen with great fps and quality. Now, I am unable to play any game (although Minecraft runs on the IGPU) at more than 2fps because the laptop will only use the integrated GPU. No, I didn't mess around with settings or download any malware. Sometimes when I am playing a game, I can see that the NVIDIA card is being used, but so is the integrated. When I open CCleaner, it sees the IGPU and not the dedicated GPU. Also, the Oculus Client tells me that my specs are below minimum, once again because it only sees the integrated GPU.

I have tried everything, from selecting the 'High-Performance NVIDIA processor' in NVIDIA Control Panel, to right clicking and selecting 'Run with graphics processor' > ''High-Performance NVIDIA processor (default)', to selecting specific apps and games and making them run on the dedicated GPU in Windows Settings. I have even tried to disable the integrated GPU in Device Manager, but then Minecraft and also the Oculus Client were unable to run. Any help would be much appreciated.
 

Attachments

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
PC Experience
Very Experienced
Hi and welcome to FpcH

If you have selected ''High-Performance NVIDIA processor (default)', and the system is still defaulting to the onboard graphics then it could be a problem with the graphics card itself.

Do you have another that you can try?

I assume that you have tried uninstalling and re-installing the NVidia drivers ?
 

Lucky26

FPCH Member
Joined
Jan 28, 2021
Location
London
PC Experience
Some Experience
Hi and welcome to FpcH

If you have selected ''High-Performance NVIDIA processor (default)', and the system is still defaulting to the onboard graphics then it could be a problem with the graphics card itself.

Do you have another that you can try?
No, unfortunately I don't have another GPU. Sometimes the dedicated GPU does show usage in task manager but it is usually below 30%. This also only happens when the IGPU is at a high usage %.
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
PC Experience
Very Experienced
Try re-installing the drivers.

You could try re-seating the Graphics Card.

If you have a volt-meter you could check the voltages on the suplimentary power supply [ 8 pin I think ]
If the cables to the connector are yellow and black the yellow cables should be 12v [ black are ground ]
 

Lucky26

FPCH Member
Joined
Jan 28, 2021
Location
London
PC Experience
Some Experience
I am not too sure if I will be able to re-seat the GPU as this is a laptop, is it possible to do that on a laptop?
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
PC Experience
Very Experienced
Sorry - assumed it was a desktop.

You are very limited now as to what you can do.
If re-installing the drivers doesn't solve it I am not sure where you can go with this.
 

Lucky26

FPCH Member
Joined
Jan 28, 2021
Location
London
PC Experience
Some Experience
Yes, I have re-installed the drivers and that didn't seem to work. Thanks for the help anyways!
 

Lucky26

FPCH Member
Joined
Jan 28, 2021
Location
London
PC Experience
Some Experience
Finally! I fixed it by switching to 'Discrete Graphics' in the BIOS!
 

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
PC Experience
Very Experienced
Thanks for the feedback.

Good to hear that you solved it :)
 
Top Bottom