• Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

[Solved] Unsure what forum this should be on?

PEV

Free PC Help Contributor
Joined
Jan 26, 2012
Messages
422
PC Experience
Some Experience
#1
Hi all and first seasons greetings to you all.
I'm taking the liberty of pasting this post which I have had on 'hardware issues' for a few days with no response - I do appreciate at this time of year lots of you will be busy but I'm just hoping to get a response! Here is the post.


optical mouse not working after Tomtom download
'I just downloaded maps etc onto my new tomtom satnav via my desktop windows 8.1 from the official Tomtom download site the download took ages so I went out for an hour but it seemed to work. However at some point my optical mouse completely stopped working (no light no pointer nothing!!) I have tried moving to a different USB point on my PC, PC on/off but nothing works. I'm wondering if the download caused this? and what can I do somebody please help!
Ray'.

New today! I have today spent hours on phone with Tomtom technical help (Indian call centre) so difficulty understanding each other! No progress in getting the download of maps etc I get about 25% download in an hour then conflicting messages 'download complete/not complete/maps corrupted maps' and my mouse dies They have not a clue why my optical mouse ceases working but I can get it back by re booting which worked once and when I tried another download today I could only get the mouse back by doing a system restore back to an earlier date. -- I think I will have to take the Tomtom back to where I bought it and get a replacement and see if the problem was a one of and try again.
Any ideas please
Ray​
 

Starbuck

Admin & Security Team
Joined
Feb 19, 2010
Messages
4,553
Location
Midlands, UK
PC Experience
Very Experienced
#2
Hi Ray and a Happy New Year to you and your family.

When you reboot and get the mouse working again.... does it work fine until you try another map download?

I'm just trying to establish if it's the download that causes the problem.
 

PEV

Free PC Help Contributor
Joined
Jan 26, 2012
Messages
422
PC Experience
Some Experience
#3
Hi Pete and a HNY to you and yours also.
Yes pretty sure it's the download. The download gets so far about 25% then stops and a message appears 'you are up to date' on my PC screen but the connected Tomtom satnav says please wait download will recommence shortly. But nothing happens except first the pointer on the mouse vanishes and then light goes out. then checking through the Tomtom interface there is a message 'maps corrupted'
I have done Malwarebytes check with only the usual 'pups' and nothing shows when I check out 'Windows Defender' - I'm on Windows 8.1 by the way.
I'm pretty well had it with this and will be getting another Tomtom and trying again because I'm pretty sure it's either the device/and/or the download that's got a problem as everything my end works fine and my download speed is 14mgb
Ray
 

Starbuck

Admin & Security Team
Joined
Feb 19, 2010
Messages
4,553
Location
Midlands, UK
PC Experience
Very Experienced
#4

PEV

Free PC Help Contributor
Joined
Jan 26, 2012
Messages
422
PC Experience
Some Experience
#5
Thanks for this Pete
Aha! I just wonder if my AV (Windows Defender or some anti advert/pop up device is causing this problem? however seems strange that the down load gets so far and then stops and what about my optical mouse getting killed?
Anyway my son in law who bought the Tomtom for me as a Christmas pressie has taken it and will be asking for a replacement from the shop and then trying to install the downloads using his computer so we may get some answers there?
Watch this space!!
Ray
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,333
Location
Wirral UK
#7
Hi Ray
Happy New Year to you and yours :)

I doubt that the device itself is at fault - but it will do no harm to swap it.
I suspect that the problem is either a corrupt download or the fact that your AV and security software is active during the download.

Let us know how you get on :)

I will delete the post that has had no replies.
 

PEV

Free PC Help Contributor
Joined
Jan 26, 2012
Messages
422
PC Experience
Some Experience
#8
Hi Ken
Happy 2016 to you to!
Having obtained (swopped) an identical Tomtom My son in law is coming round to try the download againin the morning.
Are you saying that I should disable my AV (Windows Defender) during the download? This is the only AV or anti malware active on my PC and always if any programme is to be downloaded Windows Defender asks me if I want to allow the programme onto my PC and I have to click 'yes' before proceeding. so I don't imagine the problem is caused by my AV blocking the download. do you agree this shouls be correct?
If you can reply before 9-30 tomorrow morning as we try to do the download around that time in the morning.
Thanks
Ray
 

PEV

Free PC Help Contributor
Joined
Jan 26, 2012
Messages
422
PC Experience
Some Experience
#9
Ken and Pete
I've got the problem sorted
The fault was with me not the Tomtom device!
I had the connector from the device pushed into what I presumed was the correct USB port which showed the USB symbol and also with 'SS'.
When we tried to download from Tomtom site and into the device once again halfway through the download my optical mouse died!
However my son in law tried re connecting to what we now presume to be a 'proper' USB port and everything has now worked!
Thanks for your help and can this thread be closed and marked as solved.
Ray
 

PEV

Free PC Help Contributor
Joined
Jan 26, 2012
Messages
422
PC Experience
Some Experience
#11
Hope I don't come over as a bit of a 'Burke'! The port I had the download cable in had the USB symbol but also SS. it was lucky we found the problem or it certainly would have never been solved and poor old 'Tomtom' would have taken all the blame LOL
Ray
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,333
Location
Wirral UK
#12
Hi Ray
Just for reference:
The "SS" = Super Speed which is a USB 3.0 port.
It should have been compatible with your device - even if this was USB 2.0
Strange.

Good to hear that you got it sorted :)