• Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

Stuck in a loop!

Labi

FPCH Member
Joined
Mar 17, 2018
Messages
115
Location
london
PC Experience
Some Experience
#1
Recently I used the command "CHKDSK /R" to help speed up opening & shutdown time on my Asus PC running windows 8.1 32 bit. Now I discover I cannot override this operation which is stuck in a loop, alternating between 3 messages over and over, continuously. "1) Preparing automatic repair 2) Diagnosing your PC 3) Repairing disk errors. This might take over an hour to complete."

Even after force closing, once on again, the operation resumes. I can't find a way to open Safe Mode in this version of windows & no DVD drive on my PC. Is there anything else I can do to end it ?
Has been running for over 24 hours without completing. Thank you...
 

Labi

FPCH Member
Joined
Mar 17, 2018
Messages
115
Location
london
PC Experience
Some Experience
#3
Hi Ken, Thanks for your help.
Re no.2 - entering Safe Mode without access to the system. Do I understand correctly: I must start with PC switched off - then power on and almost immediately (?) re-press & hold down power button and then press and hold Shift key? Should this bring up on screen the option to Restart in SM....? Sorry if any of this seems obvious but so far I've been unable to interrupt the operation despite repeated attempts to synchronise power button with Shift key to halt the command process. How long after 'power on' should I wait before trying this method?
Thanks again for taking the time to explain.
Labi
 

Rustys

Joined
Aug 28, 2017
Messages
141
Location
Here since I am not there
PC Experience
Very Experienced
#4
Are you letting it complete the scan for the chkdsk /r? If you are interrupting it in any way you may be doing damage to your HDD and it will continue to run until it is allowed to complete.
 

Labi

FPCH Member
Joined
Mar 17, 2018
Messages
115
Location
london
PC Experience
Some Experience
#5
After waiting 24 hours + I came to the conclusion it was never going to complete the scan. The same 3 x messages just keep repeating, at intervals, as though stuck in a loop. Hence my post heading.
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,267
Location
Wirral UK
#6
Has been running for over 24 hours without completing.
It shouldn't take this long.

Please confirm - when you leave it alone and you get to this stage .....
Repairing disk errors. This might take over an hour to complete."
Does it automatically go back to the first stage " Preparing Auto Repair" without you touching it?
[ This will answer Rusty's question too ]

2. You say you have no DVD drive.
Is it broken or just not provided with the machine.

3. What is the model of your Asus machine?

4. Is the OS an upgrade from Win 7 ?
If not then your "BIOS" is probably UEFI [ very fast ] and so the old methods of accessing Safe Mode just don't work.

5. Do you have a DVD or Memory Stick with Win 8.1 on it that you used to install the OS ?

==============
 

Labi

FPCH Member
Joined
Mar 17, 2018
Messages
115
Location
london
PC Experience
Some Experience
#7
1) Yes: 3 x messages repeat alternately.

2) No DVD drive with this model.

3) TP300L

4) Came loaded with Win 8.1

5) Don't have either DVD or M stick with OS.

(The process continues uninterrupted even with the lid shut!)
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,267
Location
Wirral UK
#8
OK thanks for the extra info.

Try this.
1. Switch off with power button [ hold it down for 5 seconds or so ]
2. Power on again.
3. When it starts to boot switch off again with power button.
Do this 3 or 4 times.

I am hoping that the machine will go into Automatic Repair mode.
If you manage to get this far click on "Advanced Options"
Then click on "Startup Repair"
The system should restart then give you an option as to which account to use.
[ select an Admin account ]
You will need a password for this account or if no password set leave the box empty.
The system will look for problems and automatically fix them.
 

Labi

FPCH Member
Joined
Mar 17, 2018
Messages
115
Location
london
PC Experience
Some Experience
#9
Tried switching on and off allowing different intervals in between. Tried switching off almost immediately after starting - several times: tried leaving it to run for 10 -15 seconds before switching off. Tried waiting for the message "preparing automatic repair" - then switching off once it shows. Even tried waiting for the blank screen which follows the first message for a short while before it goes on to say "diagnosing your PC". In short; tried every ON/Off combination without success. only thing I haven't tried is prolonged immersion in Regents canal...yet! Thanks for your input, though. Labi.
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,267
Location
Wirral UK
#10
Hi again Labi

I found the manual [I think ] for your machine which may prove useful.
http://dlcdnet.asus.com/pub/ASUS/nb...96.744860344.1521365577-1307938195.1521365577

I also found this for your specific machine - how to access BIOS - switch on and hold down the "Volume Down" button.
Asus 2.PNG
Try Disabling "Fast Boot" -see pages 84 / 85 from the manual.
Then Save the changes. [ F10 ]

Now try booting up again and try the Safe Mode options.

==========================

If Safe Mode is not a possibility - use the same method to get to the screen above and select "Recovery" option
You need to select - Refresh Your PC"
DO NOT select "Reset Your PC"

Follow the instructions - you need to select an account with Admin privileges - you will also probably need the account password.

You must select Refresh so that your files, photos etc are not affected.

If you select Reset you will definitely lose data.

===========================

EDIT:
I found a suggestion that you use F9 after switching on to get to Advanced Options Screen.
Give this a try.
 
Last edited:

Labi

FPCH Member
Joined
Mar 17, 2018
Messages
115
Location
london
PC Experience
Some Experience
#11
Ken, Your "Edit" proved to be my salvation! Where all else had failed, finally my PC accepted the F9 command and brought up the Setup menu as predicted.
However, since that eureka moment, inadvertently, I've moved deeper into unfamiliar territory! Unable to get 'system restore' to operate (while offline I think?)
I opened the admin command box option and hastily typed "CHKNTFS /X C:" expecting that it would cancel the previous automatic operation which had been malfunctioning.
It seems the command was accepted but since then I've somehow navigated my way to a 'basic' screen, headlined - Aptio Setup utility - etc. which seems to allow changes to the BIOS
but I have no idea what if any changes need to be made nor how to escape and find System Restore/Refresh options, that can be enabled. I have a suspicion the C: drive
cannot now be located after the recent use of X in the last command ...? Can this be undone: will the previous 'problem' command reassert itself again?
Hoping that you can guide me back to shallow waters in due course: meanwhile, I'll chastise myself for being hasty and write 50 x "A little knowledge can be dangerous".
Thanks again for you research and advice. Best, Labi.
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,267
Location
Wirral UK
#12
Your "Edit" proved to be my salvation
I'm glad something worked :)

CHKNTFS /X C:
This should, as you rightly assumed, have cancelled the chkdsk command.

Aptio Setup utility
It seems that you are booting directly into the BIOS.
Try this:
1. Select Boot in the Aptio setup utility, select 'Launch CSM' and change to enable
Aptio BIOS.png

2. Select the Security in the Aptio setup utility, select 'Secure Boot Control' and change to disable
3. Select Save & Exit [could be F10 ]
4. Hold down the power button until the unit switches power off completely
5. Switch back on and continually hold the F9 button down - this should take you to Windows Recovery Menu as before.
6. Select 'Advanced Start Up' and wait until the recovery menu appears
7. Select ' Advanced Options'
8. Select 'System Restore' and select a date prior to when the problem occurred

Hope this works for you.
 
Last edited:

Labi

FPCH Member
Joined
Mar 17, 2018
Messages
115
Location
london
PC Experience
Some Experience
#13
Ken, I was obliged to reverse the order of steps 1 & 2 before progressing, saving (F10) each time. Now I find as soon as I power up
I'm asked for the Admin password - which I'd previously installed (?!) when I first found myself confronted by the BIOS screen.
Entering it just takes me back there again. Pressing F9 doesn't seem to interrupt the cycle this time, though.
Is there any way back to the Recovery menu from here...? Thanks again, Labi.
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,267
Location
Wirral UK
#14
I was obliged to reverse the order of steps 1 & 2
Not sure why you would need to do this ??

Now I find as soon as I power up I'm asked for the Admin password
You say you are using the correct password ?
The password will be case sensitive - please check this.

Entering it just takes me back there again.
Ahh - do you mean that your password is accepted but you end up back in the BIOS ?

If you are back in the BIOS have a look for the Boot Order [ or similar ]
You may need to highlight Boot Option Priorities or similar.
The HDD [ Hard-Drive ] should be first in the boot order.
If it isn't move it up - [ it will tell you how on screen ]
Save and Exit

Try again.
 

Labi

FPCH Member
Joined
Mar 17, 2018
Messages
115
Location
london
PC Experience
Some Experience
#15
Ken, Under 'Boot Option Priorities' - "Boot Option #1 -----[Windows Boot Manage...]".... is shown.
Clicking on it brings the option to "disable": nothing else.

Scrolling down and clicking on "Add new Boot Option", opens a box for me to type a command/option.

Nowhere do I see any screen reference to HDD for me to select...?

I confirm "launch CSM" now shows "Enabled" - and "Secure Boot Control" is "Disabled".

Not quite sure if - at this point, I'm waving or drowning..! Labi.
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,267
Location
Wirral UK
#16
Pressing F9 doesn't seem to interrupt the cycle this time,
This is because we enabled CSM [ Compatibility Support Module ]
CSM allows the more advanced UEFI bios to run as a Legacy BIOS. [ i.e. the older version ]
In this configuration F9 may not work as it is a feature of UEFI.

Try the following:
1. Leave the BIOS settings as they are.
2. Switch off using the Power Button [ hold down until complete shut down ]
3. Switch on again.
4. Immediately repeatedly tap F8 key [ quite fast ]
Hopefully this may give you an option to load Safe Mode.

5. If not try the same process but this time after switching on to attempt to boot up - hold Shift down and repeatedly tap F8 [ quite fast ]

=======================

If this doesn't give us access to Safe Mode go back into the BIOS and change CSM to "Enable"
Save and Exit.

Power off as before.

Power on and try F9 again

=======================
Hopefully you can get to a screen similar to this. [ see below ]
Can you ?

What options show ?

If "System Restore" is an option give this a try and select a date prior to the start of your problem.
Be aware that you will lose installed software and updates but not files or photos etc.

Advanced Options2.PNG
 

Labi

FPCH Member
Joined
Mar 17, 2018
Messages
115
Location
london
PC Experience
Some Experience
#17
Ken, not having success atm. The Admin password box appears so quickly on screen after power on, F numbers don't interrupt, no matter what I try.
Just to recap: launch CSM- is Enabled... and Secure Boot Control is Disabled.

In the Boot menu is the opportunity to "Add new Boot Option" underneath which is "Path for boot option" and below that - the word "Create".
Could this be at all helpful in choosing/creating an alternative Boot command path to break the impasse..?

BTW: In your last reply - after no.5, you say ..."go back into the BIOS and change CSM to 'Enable' save and exit."
In fact, at the moment CSM is already enabled following your earlier advice....?

Sorry; I find myself stuck in another loop after jail-breaking with F9 before. Thanks again for staying with me.
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,267
Location
Wirral UK
#18
Hi
Sorry that line should have read ....
If this doesn't give us access to Safe Mode go back into the BIOS and change CSM to "Disable"
Don't forget to Save and Exit.
Power off then switch on again.
Try F9 again.
 

Labi

FPCH Member
Joined
Mar 17, 2018
Messages
115
Location
london
PC Experience
Some Experience
#19
I have tried already to restart with CSM Disabled & Enabled, alternately, using each F key, experimentally.

In case it helps, in the Boot menu, under Boot Config. - Fast Boot is set to Disabled. Launch CSM is currently set to Disabled.




Boot Option #1... shows [Windows Boot Manage...] which, when highlighted, allows Disabled to be selected.

Again, just in case it's at all relevant: in the Security menu, the following advice is found under Password Description.

"If ONLY the Administrator's password is set, this only access to Setup and is only asked for when entering Setup. If ONLY the User's
password is set, this is a power on password and must be entered to boot to enter Setup. In Setup the User will have Administrator rights."

(I've copied it exactly: haven't omitted anything accidentally!) I can't divine the meaning of this and it's probably not related to the 'problem' - but you never know...

Further down the Security page.

User Password Status - Not Installed.
HDD password Status - Not Installed.
Secure Boot menu - when highlighted, reads....Platform Mode - User
Secure Boot - Disabled
Secure Boot Control - [Disabled]

If there are any other Boot-up/PC settings that might affect this 'problem' please let me know and I'll try to give an update re status. (This email programme is behaving erratically atm. Sorry if anything repeats) Best, labi.















If there are any other settings governing Boot-up behaviour, please let me know. I'll take a look and give status update.
Best, Labi.
 

KenB

Administrator
Joined
Oct 19, 2008
Messages
9,267
Location
Wirral UK
#20
Hi Labi

"If ONLY the Administrator's password is set, ..........etc
In this case "Setup" refers to the BIOS. You don't have a User password set. It appears that you do have an Admin password set which is why you are being asked for an Admin password when you boot up and it is attempting to enter the BIOS. [ unless it is booting past this - in which case you don't have as Admin password set either ]

We made 2 changes in post #12
We changed CSM and have since put it back to Disable
This is the default and what it should be set to now.

We changed Secure Boot Control to Disable in post #12
Please go back and change this to Enable.

Now Save and Exit.

We should now be back to where we started.

Hold the power key down until the machine fully switches off.
Power back on and immediately hold down the F9 key.

Hopefully this will take us to the Advanced Options Screen again.

If it does then try System Restore to a date prior to the start of your problems.
 
Last edited: