• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

System CPU / Hardware Problem;+ Sound Card Drivers lost after reformat.

dgalexan

FPCH Member
Joined
Apr 8, 2008
Messages
8
PC Experience
Some Experience
Operating System
Windows Vista - Ultimate
#1
Hi this is my first post so excuse the fact that it maybe in the wrong section.

I have recently swapped hard disks in my machine. This i did by removing the battery off the motherboard (letting it drain for 30 mins) and reloading bios settings after connecting the new hard disk. The hard disk seems to be working fine as i have reformatted with XP no problem.

1. However before i set the bios to boot from CD:ROM for the XP format, on the BIOS settings it said "CPU Type UNKNOWN". Although the system seems to work fine will i incur any problems at a later date? ( it does recognize the CPU speed by reloading system defaults just not the CPU type)

2. I have also found that whilst reformatting xp the sound card is not recognized. Does any one know of a good program to scan my hardware so i can find the name of the pci card so i can Google it to retrieve the drivers? Or is this a different problem?

Thanks, i hope it makes sense

Dave :confused:
 
W

Wolfeymole

#3
Hi Dave

Why did you pull the cmos batt to change a hard drive?

Let me suggest that what actually happened was that you tried to install a hdd with XP on that drive.
The hardware parameters on that drive did not match the hardware on the machine you installed it to, hence "CPU not recognized"
You then decided to format the drive and now you need the system drivers yes?
 

dgalexan

FPCH Member
Joined
Apr 8, 2008
Messages
8
PC Experience
Some Experience
Operating System
Windows Vista - Ultimate
#4
"Let me suggest that what actually happened was that you tried to install a hdd with XP on that drive."

Ye
s that is a better way of putting it. I removed the battery to swap the hdd which did have xp on it set up from another computer.

"You then decided to format the drive and now you need the system drivers yes?"

However after formatting with the new hdd the system seems to work fine. do i still need the system drivers? (i did reload default bios settings, although this only found CPU speed not CPU TYPE)

cheers; dave

 
W

Wolfeymole

#5
Yes you will still need the drivers or the ones that are not included in the XP database at least.
 

dgalexan

FPCH Member
Joined
Apr 8, 2008
Messages
8
PC Experience
Some Experience
Operating System
Windows Vista - Ultimate
#6
I Understand that i need them for pci cards ect...but does this apply to the CPU?
 
W

Wolfeymole

#7
The cpu does not need a driver.

What board do you have and what CPU did you insert?
Run the software that Maynard suggested to ascertain.
 

dgalexan

FPCH Member
Joined
Apr 8, 2008
Messages
8
PC Experience
Some Experience
Operating System
Windows Vista - Ultimate
#8
I have just ran that software on another machine and its straightforward enough, however i wont have access to the machine with the problem for a couple of hours (8 pm) will update you later,

Thanks again for the patience. Im new to this site but its already proving to be a life saver.

Thanks Wolfeymole + maynardvdm

dave :D
 

dgalexan

FPCH Member
Joined
Apr 8, 2008
Messages
8
PC Experience
Some Experience
Operating System
Windows Vista - Ultimate
#10
Used the program and i got the sound card drivers no problem. It also recognized the CPU and it boots up fine. :)