• Welcome to Free PC Help, a free PC Help forum to get help with your computer problems.

    Free PC Help is a community that offers free computer help and support for all users, all ages, worldwide.

    In order to start asking questions or contribute on someone else's post you will first need to register. Don't worry - it's quick and easy and once you have registered you will have instant access to the entire forum.

    If you do decide to join the forums you will not have the option to send Private Messages [ PMs ] or add a Signature until you have made 5 posts or more. This is an attempt to try to stop Spammers using the PM system or adding links to their Signature.

Yahoo Mail keeps asking for email address

blkbrd37

Free PC Help Contributor
Joined
Nov 28, 2014
I have the same problem as RoyPks with Yahoo Mail except that it keeps asking me to enter my email address and the accepts my password automatically. Why??????????

See RoyPks thread here - click here

[ edited by KenB ]
 
Last edited by a moderator:

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
Hi blkbrd37,

I have split your post from the other one - you are better with your own .........less complicated :)

To clarify :
When you login to your Yahoo Mail you expect it to go directly to your Inbox but you are asked to login with your email address every time.
It automatically fills in your password.

Is this correct ?

When you login - do you have "Stay Signed In" checked ?
 
Last edited:

KenB

Administrator
Joined
Oct 19, 2008
Location
Wirral UK
If you have "Stay signed in" checked then it could be that you are deleting the yahoo cookie after each session.

A cookie is a small piece of software that tells Yahoo that you are a returning customer.
If the cookie is deleted then you will be treated as a first time login.

If you are using Edge [ as per your profile ]
Type ....edge ..... into the search bar [ bottom left of screen ]
Click on Microsoft Edge in the left panel. [ Edge will open ]
Click on the three dots [ top right ]
Scroll down to "Settings"
Scroll down to " What to Clear" and click on this
Check to see if "Always Clear This When I Close The Browser" is Off.
If it is On then change it.

Alternatively - uncheck the box next to "Cookies and Saved Web Data "
You can then leave "Always Clear This ......... " set to ON.
 
Last edited:
Top Bottom